Cydia Impactor Error provision.cpp:71 oder provision.cpp:81 - So beseitigt man diese Fehler

23.03.2017 10:15 Uhr | Zeiram

Mit dem Cydia Impactor wird es iOS Nutzer, wenn auch mit kleinen Einschränkungen, leicht gemacht IPA Dateien für Emulatoren oder Freeware auf dem iPhone, iPad oder iPod Touch zu installieren. So manches Mal streikt das Programm aber und produziert Fehler. Wie Ihr die Cydia Impactor Fehlermeldungen provision.cpp:71 oder provision.cpp:81 beseitigen könnt zeigen wir euch in diesem Ratgeber.

Begleitet wird der Fehlercode meist von der Meldung „You already have a current iOS Development certificate or a pending certificate request“ begleitet. Diese Fehler können mehrere Ursachen haben. Der häufigste und am leichtesten zu behebende Fehler wäre eine veraltete Cydia Impactor Version. Geht im Reiter „Impactor“ auf „Check for Update“, prüft so ob eine neue Version verfügbar ist und installiert diese auch sofern vorhanden.

Ist dies nicht der Grund und es gibt keine neue Version muss man die Zertifikate die man bereits durch Cydia Impactor erhalten hat vielleicht Widerrufen. Geht dazu auf den Reiter „Xcode“ und wählt dort die Option „Revoke Certificates“ aus. Ihr müsst euch dann mit eurer Apple ID anmelden. Je nach Internetverbindung kann dieses Prüfung einen Moment dauern.

Wird gemeldet, dass eine bestimmte Menge an Zertifikaten „revoked“ wurden sollte das Ganze nun auch funktionieren. Wird das Ganze aber für 0 Zertifikate gemeldet hat man nach wie vor ein Problem. Hier kann man dann noch versuchen bestimmte APP IDs zu löschen.

Das ist allerdings nicht so dramatisch wie es klingt. Geht im Schritt zuvor auch auf „Xcode“ und wählt dann „Delete App ID“ Option. Auch hier müsst Ihr euch wieder über die Apple ID anmelden und nach einem Moment öffnet sich ein Fenster mit den Apps die Ihr bereits per Cydia Impactor genutzt habt. Löscht diese nach und nach, es geht immer nur eine pro Schritt, und spätestens wenn sie leer ist funktioniert es hoffentlich wieder.

Bringt auch das keine Lösung ist aktuell eine neue Apple ID für die Nutzung mit dem Cydia Impactor nötig, oder man muss warten bis eine aktuelle Version erscheint. Viele User haben das Problem scheinbar auch nachdem sie mit BaytSigner experimentiert haben, so dass auch hier somit noch mehr Grund zur Vorsicht geboten zu sein scheint!

Meinung des Autors

Cydia Impactor ist nicht frei von Fehlern, man sollte aber auch nicht zu experimentierfreudig sein. Aktuell tritt der Fehler scheinbar öfter auf als sonst, und BaytSigner scheint daran nicht ganz schuldlos zu sein…

Ähnliche Artikel

iOS 13 - Dunkelmodus aktivieren

iOS 13 - Dunkelmodus aktivieren

Mit iOS 13 wird Apple endlich einen der grossen Wünsche der User erfüllen und einen echten „Dunkelmodus“ einführen. Warum dies so lange gedauert... mehr
Oben